wsa-helpcenter-white

Woosa Server Recommendations

Before you start with one of the Woosa plugins for WooCommerce, it is smart to check our Server Recommendations.

Overview #

Following the Server Recommendations is not only recommended for the plugins of Woosa, but also for WordPress plugins in general. The minimum requirements we advise are relatable to the requirements WordPress and WooCommerce advise also.

Server Requirements #

Even though we expect that you already have set up an online store with WooCommerce, it is never a waste of time to check and update the requirements below.

  • PHP version 7.4 or greater
  • MySQL version 5.6 or greater OR MariaDB version 10.1 or greater
  • WordPress memory limit of 256 MB or greater
  • HTTPS support

You should also check the WordPress requirements.

PHP version less than 7.3+ and MySQL version less than 5.6 no longer receive active support and many versions are at End Of Life and are therefore no longer maintained. As such, using outdated and unsupported versions of MySQL and PHP may expose your site to security vulnerabilities.

Optional Recommendations #

We recommend the below optional items:

  • CURL or fsockopen support, used by Woosa and by several of our integrations, e.g. bol.com
  • Additional requirements with regards to Permalinks, which should not be set to “Plain” but any other option in case of several of our integrations, e.g. vidaXL, BigBuy

Questions and Support #

Do you still have questions after reading this article?

  • Submit a Ticket for our Technical Support Specialists. We provide support for plugins developed by and/or sold on Woosa.com.
  • Get in touch with our Customer Success Manager, also if you’re not a customer at Woosa yet.